External Service Provider Outages
Incident Report for Seismic Status
Resolved
This incident has been resolved.
Posted Dec 15, 2021 - 12:37 CST
Monitoring
If you're experiencing issues logging in to Seismic, there is an ongoing data center issue at Amazon affecting some of our external service providers, including those for logging in.

The issue seems to be intermittent at this time, so if it's not working for you, please be patient.
Posted Dec 15, 2021 - 10:06 CST
This incident affected: Web and Mobile (Android, iOS).