Incorrect/doubled Weight Values
Incident Report for Seismic Status
Postmortem

We identified a unit conversion bug that was converting weight units from kilos to pounds more than once. The bug was found in both Web and Mobile applications. We’ve gone through and reverted all known affected users. If you still continue to see incorrect weights please contact support@getseismic.com.

Posted Jan 20, 2021 - 12:49 CST

Resolved
Some client users are reporting that their weight numbers are inaccurate. Those who are affected are one who have chosen to use metric units.
Posted Jan 15, 2021 - 08:00 CST